class file has wrong version 50.0, should be 4x.0

갑자기 아래의 에러가 발생하면서 컴파일이 안 되네요..

class file has wrong version 50.0, should be 4x.0

원인을 찾아보니, 아래와 같은 문제로 발생한다고 한다.

errors are caused by a Java version mismatch between the compiled proxies and your runtime

아래는 컴파일러 버전과 Java 런타임 버전에 대한 내용이다.

Version 50.0 = Java 1.6.x
Version 49.0 = Java 1.5.x
Version 48.0 = Java 1.4.x

답글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다.